HTTrack Website Copier
Free software offline browser - FORUM
Subject: XMLHttpRequest problem
Author: Al
Date: 07/31/2013 22:54
(I tried to use the search function to see if this issue had come up before,
but I get an empty results page, no matter what I search for, even searching
for terms that I know have been used in recent posts to this forum).

I'm mirroring a page that includes a .js file that has a function that uses

The relevant section of code in the .js file on the server is like this:
hr_get = new XMLHttpRequest();'GET', url, true);

I see this line in the output when I run httrack:
15:14:14    Error:  "Not Found" (404) at link testweb/GET (from

The output contains a file called GET.html, and the copy of the .js file has
changed to:
hr_get = new XMLHttpRequest();'GET.html', url, true);

As 'GET' is the HTTP method (GET, PUT, HEAD, etc) I can't figure out why
httrack think it needs to be modified in any way.

I was able to work around this by modifying the original code to "hide" the

   var method = 'GET';, url, true);

but it would be better if httrack didn't mangle that bit of .js code.

All articles

Subject Author Date
XMLHttpRequest problem

07/31/2013 22:54
Re: XMLHttpRequest problem

08/12/2013 21:37


Created with FORUM 2.0.11