HTTrack Website Copier
Free software offline browser - FORUM
Subject: Re: Compiling problems
Author: Xavier Roche
Date: 06/15/2003 17:50
> according to the packetmanager, I only have libhttrack1
> installed in /usr/lib/ and
> /usr/lib/

You need to install libhttrack-dev

> My KDE version is 3.0.3.

Should be fine ; my current opinion on dependencies are:
Depends: libhttrack1, kdelibs4, libqt3c102-mt, kwrite
Build-Depends: libhttrack-dev, gcc-3.2, autotools-dev, 
kdelibs4-dev, libqt3-mt-dev, libqt3-compat-headers, 
debhelper (>> 4.0.0)

> I also tried to compile khttrack 0.9. There, the configure
> script showed no error , but running make failed with
> usr/bin/ld: cannot find -lhttrack.

I tried and apparently it is working, using the commandline:

CXX=g++-3.2 ./configure --prefix=/usr --with-qt-
dir=/usr/share/qt3 --with-qt-includes=/usr/include/qt3 && 
make && make install

But apparently there are problems with my libraries (the 
refresh screen is not displayed correctly, maybe because of 
non-mt/mt mixes in qt libs)
Reply Create subthread

All articles

Subject Author Date
Compiling problems

06/14/2003 13:27
Re: Compiling problems

06/15/2003 09:08
Re: Compiling problems

06/15/2003 13:51
Re: Compiling problems

06/15/2003 17:50
Re: Compiling problems

06/16/2003 00:21
Re: Compiling problems

06/16/2003 07:04


Created with FORUM 2.0.11