HTTrack Website Copier
Free software offline browser - FORUM
Subject: Update: --max-time=N feature . Post 3.30RC17
Author: TrashCan
Date: 09/17/2003 00:59

I installed Ver3.30-RC17 on a fresh debian install (I 
couldn't compile it on FreeBSD 4.8 which is what I use)

The problem with the 'max-time' feature seems to persist, 
httrack is not exiting after the defined timeout.
I paste you an extract of the complete command I ran which 
shows the time taken by httrack to exit when I use a wrong 
default gateway to simulate a 'timed-out' server. I 
concatenated httrack to 'time' to see the elapsed time.

debian:/var/tmp/test# time httrack <> -
O "." --mirror --depth=2 --ext-depth=0 -f0 --sockets=4 --
timeout=1 --retries=1 --host-control=1 %P --near --
structure=0 --keep-links=0 --replace-external --cookies=1 --
check-type=0 -j0 --robots=0 --cache=0 --single-log -S -N0 -
a --max-time=1
WARNING! You are running this program as root!
It might be a good idea to use the -%U option to change the 
Example: -%U smith

Mirror launched on Tue, 16 Sep 2003 15:50:35 by HTTrack 
Website Copier/3.30-RC-17 [XR&CO'2003]
mirroring <> %P with the wizard help.. (0 bytes) - -2
Thanks for using HTTrack!

real    2m0.028s
user    0m0.030s
sys     0m0.430s

Notice the --timeout=1 and the --max-time=1 I set and the 
time taken.

Best Regards,


All articles

Subject Author Date
Update: --max-time=N feature . Post 3.30RC17

09/17/2003 00:59
Re: Update: --max-time=N feature . Post 3.30RC17

09/21/2003 10:16


Created with FORUM 2.0.11